Problem Description
Tina Town is a friendly place. People there care about each other.
Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes
1
time as large as its original size. On the second day,it will become
2
times as large as the size on the first day. On the n-th day,it will become
n
times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.
Input
The first line of input contains an integer
T
, representing the number of cases.
The following
T
lines, each line contains an integer
n
, according to the description.
T≤105,2≤n≤109
Output
For each test case, output an integer representing the answer.
Sample Input
2
3
10
Sample Output
2
0
思路 由素数一个定理 若P是一个素数 那么(P-1)!mod P = P-1;若P是一个合数 那么这个等式结果为0 但4是唯一一个列外需要额外判断;
埃拉托斯尼斯定理:一个和数N在0-N^1/2的区间里必有 一个质数是他的因子;
所以我们可以根据这个定理来判断是不是素数,然后根据第一个定理来输出结果
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int prime[1000005];
bool isPrime[1000005];
void Prime()//打印素数表
{
int num = 0;
memset(isPrime,true,sizeof(isPrime));
isPrime[0] = isPrime[1] = false;
for(int i=2 ; i<= 1000005; i++){
if( isPrime[i] ) prime[num++] = i;
for(int j=0 ; j<num ; j++){
if( i*prime[j]>1000005 ) break;
isPrime[ i*prime[j] ] = false;
if( i%prime[j] == 0 ) break;
}
}
}
bool check(int n)//判断N是不是素数
{
int flag = 1;
for(int i = 0;prime[i]*prime[i]<n;i++)
{
if(n%prime[i] == 0)
{
flag = 0;
break;
}
}
if(flag)return true;
return false;
}
int main()
{
Prime();
int T;
scanf("%d",&T);
while(T--)
{
int n;
scanf("%d",&n);
if(n == 4)printf("2\n");
else if(check(n))printf("%d\n",n-1);
else printf("0\n");
}
return 0;
}