点击打开题目链接
Exam
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1993 Accepted Submission(s): 973
Problem Description
As this term is going to end, DRD needs to prepare for his final exams.
DRD has
n
exams. They are all hard, but their difficulties are different. DRD will spend at least
ri
hours on the
i
-th course before its exam starts, or he will fail it. The
i
-th course's exam will take place
ei
hours later from now, and it will last for
li
hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.
So he wonder whether he can pass all of his courses.
No two exams will collide.
Input
First line: an positive integer
T≤20
indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer
n≤105
, and
n
lines follow. In each of these lines, there are 3 integers
ri,ei,li
, where
0≤ri,ei,li≤109
.
Output
For each test case: output ''Case #x: ans'' (without quotes), where
x
is the number of test cases, and
ans
is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).
Sample Input
2
3
3 2 2
5 100 2
7 1000 2
3
3 10 2
5 100 2
7 1000 2
Sample Output
Case #1: NO
Case #2: YES
Source
The 2015 ACM-ICPC China Shanghai Metropolitan Programming Contest
Recommend
Statistic |
Submit |
Discuss |
Note
题目大意:给出n场考试需要复习的时间,考试开始的时间,考试持续的时间。判断是否会挂科。
思路:结构体存,排序。
附上AC代码:
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1e5+5;
int T;
int n;
int flag;
int kase=0;
struct edges{
int r,e,l;//复习的时间r,开始考试时间e,持续考试时间l;
}edge[maxn];
bool cmp(const edges a,const edges b)
{
return a.e<b.e;
}
int main()
{
ios::sync_with_stdio(false);
while(cin>>T)
{
while(T--)
{
flag=1;
cin>>n;
for(int i=0;i<n;i++)
{
cin>>edge[i].r>>edge[i].e>>edge[i].l;
}
sort(edge,edge+n,cmp);
if(edge[0].r>edge[0].e)flag=0;
if(flag)
{
int sum=edge[0].e-edge[0].r;
for(int i=1;i<n;i++)
{
sum=sum+edge[i].e-edge[i].r-(edge[i-1].e+edge[i-1].l);
if(sum<0){flag=0;break;}
}
}
cout<<"Case #"<<++kase<<": ";
if(flag==0)cout<<"NO"<<endl;
else cout<<"YES"<<endl;
}
}
return 0;
}